Open Measures - Mewe outage – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
All systems operational
Mewe outage
Resolved
Operational
Started about 1 month ago
Lasted 9 days
Affected
MeWe
Degraded performance from 8:57 PM to 2:29 PM
Updates
Resolved
October 24, 2024 at 2:29 PM
Resolved
October 24, 2024 at 2:29 PM
This incident has been resolved.
Investigating
October 15, 2024 at 8:57 PM
Investigating
October 15, 2024 at 8:57 PM
We are currently investigating this incident.